[MythDora] Transcode failed with status: 0

Dennis Hand d00dtv at gmail.com
Wed Feb 28 23:53:35 CET 2007


Yeah it's no big deal really. This is happening on the 3.2 FC5 version
and I'm about to come out with version 4.0 FC6 so we're good.

Dennis

On 2/28/07, Axel Thimm <Axel.Thimm at atrpms.net> wrote:
> On Wed, Feb 28, 2007 at 11:56:34AM -0500, Dennis Hand wrote:
> > > Can you check with rpm -qRp on this package? There is no such package
> > > at ATrpms, there was only lame-3.96.1-11 from 2004 (note the dash and
> > > dot position).
> >
> >
> > # rpm -qRp lame-3.96.1-11.fc5.at.i386.rpm
> >
> > /sbin/ldconfig
> > /sbin/ldconfig
> > libc.so.6
> > libc.so.6(GLIBC_2.0)
> > libc.so.6(GLIBC_2.1)
> > libc.so.6(GLIBC_2.1.3)
> > libc.so.6(GLIBC_2.3)
> > libc.so.6(GLIBC_2.3.4)
> > libc.so.6(GLIBC_2.4)
> > libm.so.6
> > libm.so.6(GLIBC_2.0)
> > libncurses.so.5
> > ncurses >= 5.0
> > rpmlib(CompressedFileNames) <= 3.0.4-1
> > rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> >
> > > Maybe it's not missing/needed at all?
> > Oh it does look to be needed as users are saying things are working
> > fine now. Just for the hell of it I ran another dependency check on my
> > version-3.2 tree and it comes back with no errors. It simply looks as
> > if this version may have just had a problem.
>
> Yes, the lib should had been listed in the above. It looks quite
> broken. Maybe it was, it's more than 2 years ago, and I remember some
> lame stuff on bugzilla and lists.
>
> Is it easy to update the package in the iso? Or are you going straight
> for FC6/F7?
>
> > Dennis
> >
> >
> > On 2/28/07, Axel Thimm <Axel.Thimm at atrpms.net> wrote:
> > > On Wed, Feb 28, 2007 at 09:37:04AM -0500, Dennis Hand wrote:
> > > > Hmmm, thats very odd. I can do a dependency check on my FC5 tree and
> > > > libmp3lame won't come up as a missing dependency. This is an older
> > > > version of lame-3.96-1.11 so not sure if that has anything to do with
> > > > it.
> > >
> > > Can you check with rpm -qRp on this package? There is no such package
> > > at ATrpms, there was only lame-3.96.1-11 from 2004 (note the dash and
> > > dot position).
> > >
> > > In fact it's very difficult to not have these dependencies created,
> > > because rpm does that automatically.
> > >
> > > > It's not a big deal really. I just found it odd that alot of my
> > > > members started posting about all these ripping and transcoding
> > > > problems and finally someone posted saying that this one rpm was
> > > > missing. I do have this in the new FC6 build so I'm all good now.
> > >
> > > Maybe it's not missing/needed at all?
> > >
> > > > Dennis
> > > >
> > > > On 2/28/07, Axel Thimm <Axel.Thimm at atrpms.net> wrote:
> > > > > On Tue, Feb 27, 2007 at 10:39:17PM -0500, Dennis Hand wrote:
> > > > > > >How can that happen (technically)? Isn't this checked by anaconda at
> > > > > > >creation time? Or is the dependency on the package missing? If it's
> > > > > > >the latter I'd like to fix that in the package.
> > > > > >
> > > > > > The libmp3lame is not a dependency of lame and it really should be. I
> > > > > > guess I should have emailed you on this but I actually just found this
> > > > > > out a short while ago. I do a total dependency check on my install tree
> > > > > > just before I build a new ISO and libmp3lame never came back as a
> > > > > > missing dependency and this is why I didn't catch it. This is on the FC5
> > > > > > build but FC6 lame does require libmp3lame.
> > > > >
> > > > > The lame package has the following dependency:
> > > > >
> > > > > $ rpm -qR lame | grep mp3
> > > > > libmp3lame.so.0()(64bit)
> > > > >
> > > > > (That's on x86_64, so you get the extra '()(64bit)', but the same holds
> > > > >  true for i386)
> > > > >
> > > > > This is provided by
> > > > >
> > > > > $ rpm -q --whatprovides 'libmp3lame.so.0()(64bit)'
> > > > > libmp3lame0-3.97-15.fc6.at
> > > > >
> > > > > If I check the same on FC5/i386, and even use repoquery I find the same:
> > > > >
> > > > > # repoquery -q --whatprovides 'libmp3lame.so.0'
> > > > > libmp3lame0-0:3.97-15.fc5.at.i386
> > > > > # rpm -e libmp3lame0
> > > > > error: Failed dependencies:
> > > > >         libmp3lame.so.0 is needed by (installed) lame-3.97-15.fc5.at.i386
> > > > >         libmp3lame.so.0 is needed by (installed) libquicktime-0.9.10-18.fc5.at.i386
> > > > >
> > > > > _______________________________________________
> > > > > mythdora mailing list
> > > > > mythdora at atrpms.net
> > > > > http://lists.atrpms.net/mailman/listinfo/mythdora
> > > > >
> > > > >
> > > >
> > > > _______________________________________________
> > > > mythdora mailing list
> > > > mythdora at atrpms.net
> > > > http://lists.atrpms.net/mailman/listinfo/mythdora
> > >
> > >
> > > _______________________________________________
> > > mythdora mailing list
> > > mythdora at atrpms.net
> > > http://lists.atrpms.net/mailman/listinfo/mythdora
> > >
> > >
> >
> > _______________________________________________
> > mythdora mailing list
> > mythdora at atrpms.net
> > http://lists.atrpms.net/mailman/listinfo/mythdora
>
> --
> Axel.Thimm at ATrpms.net
>
> _______________________________________________
> mythdora mailing list
> mythdora at atrpms.net
> http://lists.atrpms.net/mailman/listinfo/mythdora
>
>



More information about the mythdora mailing list