[ATrpms-users] Conflicting Asterisk package?

Axel Thimm Axel.Thimm at ATrpms.net
Thu Apr 24 12:03:57 CEST 2008


On Thu, Apr 24, 2008 at 11:47:10AM +0200, Angel Marin wrote:
> Axel Thimm wrote:
> > On Thu, Apr 24, 2008 at 10:16:36AM +0200, Angel Marin wrote:
> >> Axel Thimm wrote:
> >>> Hi,
> >>>
> >>> On Wed, Apr 23, 2008 at 01:56:53PM +1000, Jean-Yves Avenard wrote:
> >>>> Trying to upgrade to asterisk 1.4.19 and saw the asterisk-sounds package.
> >>>>
> >>>> %smart install 'asterisk-core-sounds' 'asterisk-sounds'
> >>>>
> >>>> and I get hundreds of messages like this:
> >>>> "ds-1.2.1-8.at conflicts with file from package asterisk-1.4.19-60.el5
> >>>> error: file /var/lib/asterisk/sounds/silence/5.gsm from install of
> >>>> asterisk-sounds-1.2.1-8.at conflicts with file from package
> >>>> asterisk-1.4.19-60.el5
> > 
> >> #1186 comments 17-20 were about this upgrade path. The
> >> Provides/Obsoletes for asterisk-sounds are in asterisk-extra-sounds spec
> >> in asterisk-extra-sounds-en-gsm subpackage so no idea why upgrade
> >> process isn't doing it's magic.
> > 
> > Yes, that 's strange. And it breaks with smart/yum/apt in the same way :(

I forgot to mention that I tried

depsolver install asterisk-extra-sounds-en-gsm asterisk-sounds

E.g. I explicitely asked for installation of two packages of which one
obsoletes/provides the other an no depsolver found this bad.

> Ok, I think I now see what's going on. It's a asterisk-core-sounds 
> install so it'll pull in asterisk-1.4 (as per Requires), but as 
> asterisk-sounds does not limit it's compatibility with asterisk 
> releases, and neither asterisk-1.4 nor asterisk-core-sounds provides 
> asterisk-sounds it generates those conflicts.
> 
> Current upgrade path will work for the 'yum update asterisk' case, but 
> not for any 'yum install asterisk-sounds-{core-extras}-{whatever}'.
> 
> So we either:
>   a) Add a 'Requires: asterisk < 1.4' to asterisk-sounds-1.2 package
> 
>   b) Add a 'Obsoletes: asterisk-sounds < 1.4' to asterisk-1.4 package. 
> This would not install a replacement package for asterisk-sounds-1.2, 
> but as most sounds are now part of asterisk-1.4 anyway it wouldn't be 
> such a bad upgrade path.
> 
>   c) Add a 'Conflicts: asterisk-sounds < 1.4' to asterisk-1.4 package. 
> This would prevent install, but would give a better clue to the user 
> that removing asterisk-sounds-1.2 will fix the problem.
> 
> I'd vouch for b) so there's no need to rebuild an ancient package while 
> providing a reasonable upgrade path for this case.

It would be the same case as above: One package obsoletes/provides the
other, and while a generic update/upgrade/dist-upgrade may do the
right thing explit install commands will fail :/
-- 
Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
Url : http://lists.atrpms.net/pipermail/atrpms-users/attachments/20080424/5a62fc24/attachment.bin 


More information about the atrpms-users mailing list