[ATrpms-users] ndiswrapper and kernel modules?

Keith C mythtv at keithandjill.com
Tue Oct 24 15:45:22 CEST 2006


On Oct 23, 2006, at 11:06 PM, Alex Kruchkoff wrote:

> Dear list users,
>
> below is the list of all kernels and kmdl packages on my box:
>
> alsa-kmdl-2.6.17-1.2187_1.fc5.cubbi_suspend2-1.0.13-55.fc5.at
> drbd-kmdl-2.6.17-1.2187_1.fc5.cubbi_suspend2-0.7.20-12.fc5.at
> ieee80211-kmdl-2.6.17-1.2187_1.fc5.cubbi_suspend2-1.2.15-14.fc5.at
> kernel-module-ATI- 
> fglrx-2.6.17-1.2187_1.fc5.cubbi_suspend2-8.29.6-1.fc5
> kernel-module-ATI- 
> fglrx-2.6.18-1.2200_2.fc5.cubbi_suspend2-8.29.6-1.fc5
> kernel-suspend2-2.6.17-1.2187_1.fc5.cubbi_suspend2
> kernel-suspend2-2.6.18-1.2200_2.fc5.cubbi_suspend2
> kernel-suspend2-devel-2.6.17-1.2187_1.fc5.cubbi_suspend2
> kernel-suspend2-devel-2.6.18-1.2200_2.fc5.cubbi_suspend2
> lirc- 
> kmdl-2.6.17-1.2187_1.fc5.cubbi_suspend2-0.8.1-62_cvs20060930.fc5.at
> ndiswrapper-kmdl-2.6.17-1.2187_1.fc5.cubbi_suspend2-1.16-4.rhfc5.at
> shfs-kmdl-2.6.17-1.2187_1.fc5.cubbi_suspend2-0.35-8.fc5.at
>
> Today's anacron job suggested to
> ...
> === smart reports available updates:
> ===
> Loading cache...
> Updating cache...                
> ########################################
> [100%]
>
> Computing transaction...
>
> Upgrading packages (8):
>   DCC-1.3.42-15.fc5.at at x86_64
>   directfb-0.9.25.1-10.fc5.at at x86_64
>   imlib2-1.3.0-6.fc5.at at x86_64
>   libdirect-0.9_25-0.9.25.1-10.fc5.at at x86_64
>   libfusion-0.9_25-0.9.25.1-10.fc5.at at x86_64
>   lirc-0.8.1-63_cvs20060930.fc5.at at x86_64
>   lirc-lib-0.8.1-63_cvs20060930.fc5.at at x86_64
>   ndiswrapper-1.27-5.fc5.at at x86_64
>
> Installing packages (2):
>   kernel-xen-2.6.18-1.2200.fc5 at x86_64
>   ndiswrapper-kmdl-2.6.18-1.2200.fc5xen-1.27-5.fc5.at at x86_64

This has been happening to me since sometime in mid summer.  If I was  
to guess, it went looking for the newest ndiswrapper-kmdl and decided  
you needed a new kernel for it.  I think its a good idea to set lock  
flags (in smart) on all the kernel types you don't use (xen, xen0,  
etc).  In fact, I set a lock flag on my current kernel (and kernel- 
devel) as well until I've done my homework and made sure an upgrade  
will be painless.

Keith C

> ...
>
> Please note that first 7 upgrading packages are not related [I  
> think] to
> my question, but may be there hidden dependency..?
> My question is: why upgrading   ndiswrapper-1.27-5.fc5.at at x86_64
> triggers the installation of new kernel
> kernel-xen-2.6.18-1.2200.fc5 at x86_64 and kmdl module
> ndiswrapper-kmdl-2.6.18-1.2200.fc5xen-1.27-5.fc5.at at x86_64 but not
> ndiswrapper-kmdl-2.6.18-1.2200_2.fc5.cubbi_suspend2 ?
>
> I understand that ndiswrapper-kmdl-2.6.18-1.2200_2.fc5.cubbi_suspend2
> may not be available at the time of the anacron job, but why new xen
> kernel is suggested for installation?
> Is it a packaging error? Or may be I'm missing something?
>
> Many thanks in advance,
> Alex
>
> _______________________________________________
> atrpms-users mailing list
> atrpms-users at atrpms.net
> http://lists.atrpms.net/mailman/listinfo/atrpms-users




More information about the atrpms-users mailing list