[ATrpms-users] Re: trac on FC4 x64?

Rasmus Back rasmus.back at gmail.com
Fri Oct 7 07:47:27 CEST 2005


On 10/6/05, Axel Thimm <Axel.Thimm at atrpms.net> wrote:
> On Thu, Oct 06, 2005 at 12:53:45PM +0300, Rasmus Back wrote:
> > Hi!
> >
> > I tried installing trac on a 64 bit FC4 system, but the trac rpm
> > depends on clearsilver which isn't available for FC4 (x64).
>
> Yes, there is a build error for gcc4.
>
> > I grabbed the clearsilver rpm from FC3, which made rpm happy. tracd
> > starts up ok, but throws an exception when I connect to it,
> > apparently it can't find neo_cgi.
> >
> > Is there a problem with running trac on 64 bit systems? I tried the
> > trac rpm from Dries repo, but it had a dependency on
> > clearsilver_python which isn't available.
>
> I'm using trac with clearsilver from FC3, but I'm using apache, not
> tracd: http://ivtvdriver.org/trac/

Looks like I spoke too soon. The stand alone tracd works, but there's
a weird problem when using trac and mod_python. The trac project pages
load, but the style sheets don't. Firefox complains that the .css
files have the wrong mime-type (text/html) and refuses to load them.

My apache configuration for trac looks like this:

<Location /trac>
  SetHandler mod_python
  # use for trac >= 0.9
  #PythonHandler trac.web.modpython_frontend
  # use for latest stable release 0.8.4
  PythonHandler trac.ModPythonHandler
  PythonOption TracEnvParentDir /home/vcsadmin/trac
  PythonOption TracUriRoot /trac
  AuthType Basic
  AuthName "Trac projects"
  AuthUserFile /home/vcsadmin/conf/users.conf
  Require valid-user
</Location>

Did you see this problem on your trac server Axel?

Thanks,
Rasmus



More information about the atrpms-users mailing list