[ATrpms-users] about to do an apt-get dist-upgrade, warns that it will remove apt-get
gaberubin at gmail.com
Mon Nov 28 02:23:38 CET 2005
On 11/27/05, Axel Thimm <Axel.Thimm at atrpms.net> wrote:
> On Sun, Nov 27, 2005 at 04:44:20PM -0800, Gabe Rubin wrote:
> > Hi Axel
> > As the subject says, I am trying to upgrade my system. It has been a
> > while. However, when I do, it warns me of the following:
> > WARNING: The following essential packages will be removed
> > This should NOT be done unless you know exactly what you are doing!
> > apt rpm (due to apt)
> > I do not want to remove apt-get, and unsure of what I can do to ensure
> > that I don't. I tried the following, which I saw instructed in an old
> > post:
> > apt-get install rpm librpm4.4 apt atrpms-package-config fedora-release
> > but got the following error:
> > The following packages have unmet dependencies:
> > rpm: Depends: libselinux (>= 1.23.2) but 1.19.3-1_1.rhfc2.at is to
> > be installed
> > E: Broken packages
> Try apt-get update before (dist-)upgrade.
Sorry, I should have mentioned that I performed apt-get update first.
I do this all the time, but I know this is a common error for people
> > This is a fairly old, FC2 system, and trying not to upgrade to 3
> > (upgrading to 2 was a huge pain). Can you reccommend what I should
> > do? It is not essential to upgrade the box, but wanted to in
> > anticipation of any big myth changes.
> > Thanks in advance for the help!
> > Gabe
> Axel.Thimm at ATrpms.net
More information about the atrpms-users