[ATrpms-users] libxml2 conflicts with latest upgrade

Jonathan G. Underwood j.underwood at open.ac.uk
Fri Oct 29 13:07:27 CEST 2004


Jonathan G. Underwood wrote:
> Hi
> 
> The fedora project has just released an upgrade to the libxml2 package, 
> which seems to cause conflicts with the atrpms package. yum update gives:
> 
> Running test transaction:
> Errors reported doing trial run
> file /usr/lib/libxml2.so.2 from install of libxml2-2.6.15-2 conflicts 
> with file from package libxml2_2-2.6.10-2_11.rhfc2.at
> 
> Not sure what causes this - any ideas?
> 

To answer my own question, I see it's probably a package naming issue - 
libxml2-2 vs. libxml2_2. Where a package replaces a core distribution 
package, would it not make sense to stick with the Fedora naming 
conventions? Am i missing some subtelty?

Best wishes,
Jonathan



More information about the atrpms-users mailing list