[ATrpms-users] Re: nvidia-6106 Fatal server error: Caught signal 8. Server aborting

Axel Thimm Axel.Thimm at atrpms.net
Sun Jul 11 10:34:05 CEST 2004


On Sat, Jul 10, 2004 at 11:30:48PM -0500, Viktor Malyarchuk wrote:
> Hi Axel!
> 
> Here is what I see.
> 
> > lsmod|grep nvidia should give something like nvidia_1_0_6106, not
> > nvidia.
> 
> lsmod | grep nvidia
> nvidia               4811828  0

That's not from the rpm :(

> not nvidia_1_0_6106... but the same for 5336 and it work.

This means that the "nvidia" module is from an 5336 build (but not
from ATrpms' rpms).

> > ldd `which glxgears` | grep libGL
> > 
> > should point to /usr/lib/nvidia-graphics-1.0-6106/tls/libGL.so.1
> 
> Here is problem:
> ldd `which glxgears` | grep libGL
>         libGL.so.1 => /usr/lib/tls/libGL.so.1 (0x001c4000)
>         libGLcore.so.1 => /usr/lib/tls/libGLcore.so.1 (0x04170000)

Same like above.

> So, the problem is:
> /usr/lib/nvidia-graphics-1.0-6106/tls/libGLcore.so.1
> and
> /usr/lib/nvidia-graphics-1.0-6106/tls/libGL.so.1
> libs are missing...
> 
> I guess they should be in nvidia-graphics6106-libs, but they are not there...

No, that's OK, 6106 has a different tls approach.

You should remove everything nvidia-related, in doubt start with
removing the rpms. Then check /lib/modules, /usr/lib, /usr/X11R6/lib,
/usr/X11R6/lib/modules/{drivers,extensions} for any remnants of manual
installs.

When all is purged do a

apt-get kernel-module-nvidia-graphics6106-`uname -r`
apt-get nvidia-graphics6106

and restart X.
-- 
Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.atrpms.net/pipermail/atrpms-users/attachments/20040711/f6065615/attachment.bin


More information about the atrpms-users mailing list