[ATrpms-devel] New YafaRay available

Paulo Cavalcanti promac at gmail.com
Tue Feb 8 10:04:06 CET 2011


On Tue, Feb 8, 2011 at 6:33 AM, Axel Thimm <Axel.Thimm at atrpms.net> wrote:

> Hi,
>
> On Sat, 2011-01-29 at 09:08 -0200, Paulo Cavalcanti wrote:
> > http://people.atrpms.net/~pcavalcanti/srpms/YafaRay-0.1.1-4.fc14.src.rpm
> >
> > The package builds also for rhel5 and rhel6. Therefore, since we have
> > blender now, we can have YafaRay for rhel, too. It needs qt4 for
> > building.
>
> I patched it up a bit to support qt47 (it had some paths hardwired
> instead of querying pkgconfig).
>
> > The package renders great scenes, but has an incompatibility with
> > gettext (bugzilla #650471). A very simple workaround is provided in
> > the README.Fedora in the Yafaray-blender package (it just involves
> > changing the default qt4 theme by the user).
>
> Is this kind of documentation something that we should push up to
> www.atrpms.net? It's a blog after all.
>
>
In fact, this bug has been fixed. Nothing is supposed to link against
libgettextlib (it has some symbols conflicting with glib2).
The decision was to remove two symbolic links from gettext-devel in F15, to
avoid lining anything in the future.

That is why we rebuilt blender (release 22). It does not link to gettext any
more, and therefore
there is no more crashes.



-- 
Paulo Roma Cavalcanti
LCG - UFRJ
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.atrpms.net/pipermail/atrpms-devel/attachments/20110208/c38ca131/attachment.html>


More information about the atrpms-devel mailing list