[ATrpms-devel] F11 rpmbuild i586 issues

Brian Long briandlong at gmail.com
Thu Feb 25 18:53:09 CET 2010


On Wed, Feb 24, 2010 at 10:50 PM, Brian Long <briandlong at gmail.com> wrote:
> I'm trying to get the hwmon rpm built for F11 and something is screwy
> with the dependencies.
>
> $ rpm -qpR /home/brilong/rpms/hwmon/RPMS/i386/hwmon-kmdl-2.6.30.10-105.2.23.fc11.i586-2.6.32.8-1.fc11.i386.rpm
> /bin/sh
> /bin/sh
> /boot/vmlinuz-2.6.30.10-105.2.23.fc11.i586
> /sbin/depmod
> kernel = 2.6.30.10-105.2.23.fc11.i586
> modutils >= 2.4.14
> rpmlib(CompressedFileNames) <= 3.0.4-1
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rpmlib(VersionedDependencies) <= 3.0.3-1
>
> The F11 kernels don't provide kernel = `uname -r`, they provide the following:
> $ rpm -q --provides kernel
> kernel = 2.6.30.10-105.2.23.fc11
> kernel-drm = 4.3.0
> kernel-drm-nouveau = 12
> kernel-i586 = 2.6.30.10-105.2.23.fc11
> kernel-modeset = 1
> kernel-uname-r = 2.6.30.10-105.2.23.fc11.i586
> linux-gate.so.1
> linux-gate.so.1(LINUX_2.5)
> kernel = 2.6.30.10-105.2.23.fc11
> kernel(x86-32) = 2.6.30.10-105.2.23.fc11
>
> It sounds like my kmdl should require "kernel-uname-r =
> 2.6.30.10-105.2.23.fc11.i586" but I cannot find the macro that is
> inserting the kernel = 2.6.30.10-105.2.23.fc11.i586 requires.
>
> Any pointers would be appreciated.  By the way, my rpmbuild is as follows:
> $ rpmbuild -bb -vv --define "Autoreq: 0" --define "_topdir `pwd`"
> --define "debug_package %{nil}" SPECS/hwmon.spec

When I build the same RPM on F12 i686, the dependencies are lacking
kernel = foo, so it works.  I'm having a hard time narrowing down
which macro is adding the broken dependency on F11.  Any pointers to
how things are built for AtRPMS (which rpmbuild commands are run, etc)
would be helpful.

Thanks.

/Brian/



More information about the atrpms-devel mailing list