[ATrpms-devel] forcedeth kernel modules for RH9

Ben Stanley Ben.Stanley at exemail.com.au
Thu Feb 24 11:52:51 CET 2005


Hi,

Further to my previous email, I got some time this week to look into
this further.

First I fixed the original 0.22 forcedeth module to use kfree instead of
free_netdev. This allowed the module to load properly. However, it would
not then detect my card... (card too new).

So then I used Knoppix 3.7, with kernel 2.4.27, to see whether that
would work. That didn't work.

Then I built kernel 2.4.29 from kernel.org and did a test, and found
that it could detect and correctly operate my network card. It comes
with version 0.30 of forcedeth.

Then I back-ported the forcedeth driver to 2.4.20. It seems to work
(I've been using it today). I haven't had any issues with it so far.

So, since I've made an RPM of it to install on my system, I thought I'd
publish it here.

Enjoy!

On Fri, 2005-01-21 at 19:32, Ben Stanley wrote:
> Hi,
> 
> I tried downloading your 
> forcedeth-kmdl-2.4.20-37_40.rh9.at-0.22-2.rh9.at.athlon.rpm
> network driver modules for RH9 and installing them with your
> 2.4.20-37_40.rh9.at kernel (not smp, bigmem, just a plain kernel). I am
> using
> kernel-2.4.20-37_40.rh9.at.athlon.rpm
> 
> The rpm installs fine, but I cannot modprobe the module. I get an error:
> unresolved symbol free_netdev
> 
> I had a look in the kernel sources, and I can't find this symbol.
> However, it is used twice in the forcedeth.c file.
> 
> I also tried re-building the module, and while it built fine, it would
> not modprobe (same error).
> 
> So there's something wrong with it.
> 
> BTW, when you configure the kernel sourcecode after installing the
> kernel-source RPM, is is sufficient to just copy the appropriate
> configuration file from the configs directory to .config in the root
> kernel source directory, or is there something more you have to do
> before you can build modules off it?
> 
> Ben.
> 
> 
> 
> 
> 
> _______________________________________________
> atrpms-devel mailing list
> atrpms-devel at atrpms.net
> http://lists.atrpms.net/mailman/listinfo/atrpms-devel
> 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: forcedeth-0.30-1.rh9.bs.src.rpm
Type: application/x-rpm
Size: 19457 bytes
Desc: not available
Url : http://lists.atrpms.net/pipermail/atrpms-devel/attachments/20050224/1c0bca09/forcedeth-0.30-1.rh9.bs.src-0001.rpm


More information about the atrpms-devel mailing list