[ATrpms-devel] Re: Myth 0.17 build failure on stock FC3

Axel Thimm Axel.Thimm at ATrpms.net
Sat Feb 12 09:56:57 CET 2005


On Sat, Feb 12, 2005 at 12:28:19AM -0800, Jarod Wilson wrote:
> On Friday 11 February 2005 23:49, Jarod Wilson wrote:
> > I've got a freshly installed and upgraded FC3 box with nothing but FC3 and
> > ATrpms stable packages, and Myth 0.17 fails to build on it. I get an error
> > at the libavcodec build stage, something about missing -lqt-mt. After
> > adding KDE Red Hat's KDE (and thus Qt) to the system, no more build error.
> > Now to actually see if the resulting packages work... :-)
> 
> Argh. I retract that statement. I'm a dummy. Still not building. Watched the 
> build far enough that I *thought* it got past where it was dying, but it 
> didn't. However, it builds just fine on another one of my FC3 boxes, so I 
> dunno what the hell is going on right now... Both are smp boxes, but one is a 
> dual PIII (the failing one) and one is a dual Athlon.

Are you using parallel makes? Chris reported some issues with them,
perhaps that's it?

Bugs in parallel makes are non-determinstic (depend on order of
finished jobs), so you may once by happy and once sad.

Chris had the MAKEFLAGS variable set from outside rpmbuild, do you
also have this var set, does it contain "-j"?
-- 
Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.atrpms.net/pipermail/atrpms-devel/attachments/20050212/b0741c31/attachment.bin


More information about the atrpms-devel mailing list