[ATrpms-devel] Re: nvidia drivers

Axel Thimm Axel.Thimm at atrpms.net
Fri Apr 8 02:05:25 CEST 2005


On Thu, Apr 07, 2005 at 07:33:43PM -0400, Paulo Cavalcanti wrote:
> 
> 
> >Please post the results, so we can see what is wrong.
> >
> >remove any links
> >Do an ldconfig
> >Check with ldconfig -p | grep 'GL\.'
> >Check with ldd /path/to/some/app
> >
> 
> Removed the links I have created before.
> 
> Now  "sudo ldconfig -v"
> 
> [lua:/usr/lib/nvidia-graphics-1.0-7174/tls] ldconfig -p | grep GL
>        libGLcore.so.1 (ELF) => 
> /usr/lib/nvidia-graphics-1.0-7174/libGLcore.so.1
>        libGLcore.so (ELF) => /usr/lib/nvidia-graphics-1.0-7174/libGLcore.so
>        libGLU.so.1 (libc6) => /usr/X11R6/lib/libGLU.so.1
>        libGLU.so.1 (libc6) => /usr/lib/libGLU.so.1
>        libGLU.so (libc6) => /usr/X11R6/lib/libGLU.so
>        libGLU.so (libc6) => /usr/lib/libGLU.so
>        libGL.so.1 (libc6, hwcap: 0x8000000000000000) => 
> /usr/X11R6/lib/tls/libGL.so.1
>        libGL.so.1 (libc6, hwcap: 0x8000000000000000) => 
> /usr/lib/tls/libGL.so.1
>        libGL.so.1 (libc6) => /usr/lib/nvidia-graphics-1.0-7174/libGL.so.1
>        libGL.so.1 (libc6) => /usr/X11R6/lib/libGL.so.1
>        libGL.so.1 (libc6) => /usr/lib/libGL.so.1
>        libGL.so (libc6) => /usr/lib/nvidia-graphics-1.0-7174/libGL.so
>        libGL.so (libc6) => /usr/X11R6/lib/libGL.so
>        libGL.so (libc6) => /usr/lib/libGL.so
> 
> >
> 
> 
> [lua:/usr/lib/nvidia-graphics-1.0-7174/tls] ldd /usr/local/bin//gears | 
> grep libG
> /usr/local/bin//gears: /usr/X11R6/lib/tls/libGL.so.1: no version 
> information available (required by /usr/local/bin//gears)
>        libGLU.so.1 => /usr/X11R6/lib/libGLU.so.1 (0x00b3c000)
>        libGL.so.1 => /usr/X11R6/lib/tls/libGL.so.1 (0x00235000)
> 
> (It does not matter which aplication I try.)
> 
> Now I create the links again:
> 
> [lua:/usr/lib/nvidia-graphics-1.0-7174/tls] dir
> total 12
> drwxr-xr-x  2 root 4096 Apr  7 20:24 .
> drwxr-xr-x  3 root 4096 Apr  7 14:46 ..
> lrwxrwxrwx  1 root   20 Apr  7 20:24 libGL.so -> ../libGL.so.1.0.7174
> lrwxrwxrwx  1 root   20 Apr  7 20:24 libGL.so.1 -> ../libGL.so.1.0.7174
> lrwxrwxrwx  1 root   25 Apr  7 14:35 libnvidia-tls.so.1 -> 
> libnvidia-tls.so.1.0.7
> 174
> -rwxr-xr-x  1 root 1836 Apr  1 07:06 libnvidia-tls.so.1.0.7174
> 
> Now "sudo ldconfiog -v" again.
> 
> [lua:/usr/lib/nvidia-graphics-1.0-7174/tls] ldd /usr/local/bin//gears | 
> grep libG
> /usr/local/bin//gears: /usr/lib/nvidia-graphics-1.0-7174/tls/libGL.so.1: no 
> version information available (required by /usr/local/bin//gears)
>        libGLU.so.1 => /usr/X11R6/lib/libGLU.so.1 (0x00f54000)
>        libGL.so.1 => /usr/lib/nvidia-graphics-1.0-7174/tls/libGL.so.1 
> (0x00111000)
>        libGLcore.so.1 => /usr/lib/nvidia-graphics-1.0-7174/libGLcore.so.1 
> (0x00ffb000)
> 
> And everything is working again.

I now see what is wrong in your setup, try

rpm -V nvidia-graphics7174-libs

/usr/lib/nvidia-graphics-1.0-7174/libGL.so.1 will probably be
missing. The packages do have a symlink that does what you do in the
tls folder. The tls folder is not the proper place to do this though.

Just remove the manual links and reinstall the same package to get the
proper links.
-- 
Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.atrpms.net/pipermail/atrpms-devel/attachments/20050408/1bd2a7e4/attachment.bin


More information about the atrpms-devel mailing list